1

My directory structure is as follows

Vim/ 
-vim74/
   -autoload/
   -emmet-vim-master/
      -autoload
          -emmet/
      -plugin
      -doc
  -plugin/
  -color/
  -ftplugin/
-vimfiles/
  -autoload/
      -vim-pathogen-master
  -bundle/
      -vim-kolor-master/
      -emmet-vim-master/

  -plugin
-_vimrc
-_vimrc~

I am trying to install vim plugin but can't. Where am I missing ?

  • It's looking like you are trying install plugin via pathogen, but you don't have one. Does other 3rd party plugins work for you? – Alexander Myshov May 14 '15 at 13:26
  • None of the plugins work....what is the problem – Suraj Palwe May 14 '15 at 15:40
  • I'd recommend you to reinstall vim, because your file hierarchy kind of messy maybe something went wrong when you tried to solve this issue. After reinstaling vim install pathogen plugin, and after it just put emmet in the pathogen's bundle directory. It should work. – Alexander Myshov May 14 '15 at 16:42
3

You are missing the fact that Vim's default runtime files and directories are off limits.

Put your plugins in:

%userprofile%\vimfiles\

and your settings in:

%userprofile%\vimfiles\vimrc

For non-Windows users, plugins go into:

~/.vim/

and settings go into:

~/.vim/vimrc

If you still use 7.3 or share your config between machines that have 7.3 or 7.4, you can keep the scheme above and add this line to %userprofile%\_vimrc (on Windows) or ~/.vim(on other systems):

runtime vimrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.