0

After installing ctrlp via pathogen, my default spelling dictionary is located at:

~/.vim/bundle/ctrlp.vim/spell

Instead of its previous location:

~/.vim/spell

While I can always dig into the root cause and modify the plugin, or symlink the directory, is this normal/intentional?

  • Do you have something like set rtp^=~/.vim/bundle/ctrlp.vim/ in your vimrc? If so remove it – FDinoff May 8 '15 at 21:21
  • Yes, the instructions here: kien.github.io/ctrlp.vim say to do so. – ideasman42 May 9 '15 at 3:06
4

The instructions found at http://kien.github.io/ctrlp.vim assume you don't have a plugin manager. So it tells you to do the runtime path fiddling yourself (which is an incorrect assumption in this case).

If you read :help 'spellfile':

When a word is added while this option is empty Vim will set it for
you: Using the first directory in 'runtimepath' that is writable.  If
there is no "spell" directory yet it will be created.

You will see that vim uses the first directory that is writable in your runtime path to place the spellfile. The first directory is the ctrlp directory since you used set rtp^= to prepend the path to the runtime path.

The first solution would just be to remove the set rtp^=~/.vim/bundle/ctrlp.vim line from your vimrc since, that's what pathogen does for you. The second solution would be to change the spellfile with set spellfile=<absolute_path_to_new_file>


As an FYI, a more up-to-date fork of ctrlp is found at https://github.com/ctrlpvim/ctrlp.vim

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.