1

I have multiple versions of python on my ubuntu system, python2.7 which is default one and i have installed python3.8. I have a python module installed in python3.8 which is not installed in python2.7. so when is import that module in a python script in vim. It gives import-error. how do i switch between python interpreters in vim?

2
  • 1
    Welcome to Vi and Vim! Have a look at :help if_pyth and :help python-2-and-3
    – D. Ben Knoble
    Jul 27 at 20:51
  • You use neovim which handles this well.
    – eyal karni
    Aug 2 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.