I am building my personal and little distro of vim. I've just installed few plugins using this installer:

The vimrc file

" encoding
set encoding=utf-8

" Tabs and spaces
set expandtab
set shiftwidth=4
set smarttab
set softtabstop=4
set tabstop=4

" NerdTree configuration
nnoremap <leader>n :NERDTreeFocus<CR>
nnoremap <C-n> :NERDTree<CR>
nnoremap <C-t> :NERDTreeToggle<CR>
nnoremap <C-f> :NERDTreeFind<CR>

let g:NERDTreeDirArrowExpandable = '▸'
let g:NERDTreeDirArrowCollapsible = '▾'

The installer.sh file

# NERDTree
rm -rf ~/.vim/pack/vendor/start/nerdtree
git clone https://github.com/preservim/nerdtree.git ~/.vim/pack/vendor/start/nerdtree
vim -u NONE -c "helptags ~/.vim/pack/vendor/start/nerdtree/doc" -c q

# vim-airline
rm -rf ~/.vim/pack/vendor/start/vim-airline
git clone https://github.com/vim-airline/vim-airline.git ~/.vim/pack/vendor/start/vim-airline
vim -u NONE -c "helptags ~/.vim/pack/vendor/start/vim-airline/doc" -c q

cp vimrc ~/.vimrc

The strange thing is that files appears with a prefix and a suffix ^G. I've tried to change encoding:

^G on my NERDTRee

  • I've added that line as first line of vimrc file but the behavior is the same
    – sensorario
    Jul 27 '21 at 22:52

I solved the issue just adding syntax enable to my .vimrc file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.