2

I use two servers, both using redhat, and I need to most of work on server, not on my PC. My sysadmin did not update vim for a very long time, like, system's default vim version is 6.x, which is really horrible. Since I cannot get sudo privilege, I thought it would be good to compile vim myself from its source just for myself.

I followed instructions posted HERE, but I only used enable-pythoninterp, prefix, and with-python-config-dir options for configure. After I compiled vim (version 7.4.691) for the first machine, I moved on to the second one, with the same source code. I did the same ./configure and make, but it took forever (about an hour before I hit Ctrl+C) so I am really confused right now.

I checked the output, and I found out that everything is being repeated with following message,

config.status: creating auto/config.h
make: Warning: File `Makefile' has modification time 2.4e+09 s in the future

Why this behaviour, and how to solve this problem?

  • You may want to try to compile with the clean source code rather than using compiled source tree from first machine. Or perhaps you can check suggested answer for similar error message here: stackoverflow.com/questions/23281050/… – tivn May 7 '15 at 18:06
  • If you can move the source compilation to a local disk (one not on a network drive). Run make clean and reconfigure the project (you might need to touch all the files in the tree to set the modification time to now.) Then recompile. – FDinoff May 7 '15 at 18:46
2

OK. I solved problem by myself, and I wanted to share what I found.

I downloaded the most recent version from Google as a zip format, and I uploaded to my server, unzip, and tried to compile.

The thing is, files inside .zip did not have any Timestamp. While extracting, arbitrary timestamps were inserted. In my first server, all missing timestamps are filled with some arbitrary number, either too large or too small. Some files were stamped as year 1953, while some critical files, such as configure had year 2092-08-05.

Makefile compared timestamps and got error. This caused infinitely looping make procedure.

Solution? I just scped all extracted source codes from my 1st server, since it had no problem installing it. As I thought, those source codes had consistent timestamps. (By consistent, I mean, after unix epoch. They all had like 1979.)

So, it is highly unlikely anybody experiencing the same problem, but if so, you should check the timestamps.

  • Is this the same problem as issue 208? Please report there how to solve it, so we can perhaps change it later. – Christian Brabandt May 8 '15 at 7:16
  • I think that is the same problem with this. I posted a comment there. Thank you for noting me. – Hojin Cho May 8 '15 at 8:37
  • You can set the mtime of a file with the touch command. For example: touch Makefile. You combine this with find to run this on a large number of files: find /path/to/vim/sources -exec touch {} + – Martin Tournoij May 8 '15 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.