1

I want to use Ultisnips and get the following error:

E319: Sorry, the command is not available in this version: py3 import vim
Press ENTER or type command to continue
Error detected while processing /Users/Me/.vim/plugged/ultisnips/autoload/UltiSnips.vim:
line    8:
E319: Sorry, the command is not available in this version: py3 from UltiSnips import UltiSnips_Manager

I think this correlates to the fact that I get 0 as the output when running :echo has('python3'). How can I fix this issue?

My operations system is macOS Big Sur.

I have tried several times to reinstall vim with home-brew but I still get enter image description here

when executing vim --version. Any idea how one can fix this on MacOS?

5
  • 1
    See this (looks like the homebrew version includes python3 support) and this or this
    – statox
    Jun 1 at 17:11
  • 1
    Welcome to Vi and Vim!
    – D. Ben Knoble
    Jun 1 at 22:12
  • @statox I don't have a ./configure file
    – Rhi
    Jun 2 at 10:03
  • The configure file is present in the git repository of vim you'll have to use if you build vim from sources.
    – statox
    Jun 2 at 10:43
  • vim installed with homebrew should have python3 support. Once you have installed it, check it is the homebrew version you are invoking with which vim. I wonder if, judging by your duplicate question, you are still invoking system vim. Jun 2 at 10:56
0

It looks like there's some issue with your Homebrew setup or with the Vim build in your Homebrew.

When you type which vim does it show you /usr/local/bin/vim? That's the one from Homebrew. If it doesn't and lists /usr/bin/vim instead, does echo $PATH list /usr/local/bin somewhere at the start?

If you try /usr/local/bin/vim --version does it show support for +python3 (or ``+python3/dyn`) as expected?

If it looks like your Homebrew setup might be broken, try the brew doctor command to try to diagnose and/or repair it. See also Homebrew Common Issues for instructions on how to completely reinstall it, if needed.

2
  • yes, I this must be the issue, I'm getting /usr/bin/vim, brew doctor doesn't give any information concerning this however.
    – Rhi
    Jun 2 at 21:49
  • Maybe try reinstalling Homebrew? I believe it will try to modify your ~/.bash_profile or ~/.zshrc to add /usr/local/bin to the $PATH, but I don't recall which file exactly it will change and how... That's probably where the problem with your setup is.
    – filbranden
    Jun 2 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.