I'm Japanese so I'm using IM.

In my IM settings, Ctrl+Backspace is assigned to the "undo the last conversion" functionality. This shortcut usually works on normal programs (e.g. on Mozilla Firefox).

However, in vim (insert mode), it seems Ctrl+Backspace is treated as "move cursor left though this is insert mode".

How can I use IM's Ctrl+Backspace?

None of :unmap <C-BS>, :unmap <C-BackSpace>, :unmap <C>-<BackSpace> worked with the error E31: No such mapping.

None of :help CTRL-BS, :help CTRL-BACKSPACE helped me (not found).


Startup Command

$ vim -u NONE


$ vim --version
VIM - Vi IMproved 8.2 (2019 Dec 12, compiled May 02 2021 18:16:24)
macOS version - arm64
Included patches: 1-2825
Compiled by Homebrew
Huge version without GUI.  Features included (+) or not (-):
+acl               -farsi             +mouse_sgr         +tag_binary
+arabic            +file_in_path      -mouse_sysmouse    -tag_old_static
+autocmd           +find_in_path      +mouse_urxvt       -tag_any_white
+autochdir         +float             +mouse_xterm       -tcl
-autoservername    +folding           +multi_byte        +termguicolors
-balloon_eval      -footer            +multi_lang        +terminal
+balloon_eval_term +fork()            -mzscheme          +terminfo
-browse            +gettext           +netbeans_intg     +termresponse
++builtin_terms    -hangul_input      +num64             +textobjects
+byte_offset       +iconv             +packages          +textprop
+channel           +insert_expand     +path_extra        +timers
+cindent           +ipv6              +perl              +title
-clientserver      +job               +persistent_undo   -toolbar
+clipboard         +jumplist          +popupwin          +user_commands
+cmdline_compl     +keymap            +postscript        +vartabs
+cmdline_hist      +lambda            +printer           +vertsplit
+cmdline_info      +langmap           +profile           +virtualedit
+comments          +libcall           -python            +visual
+conceal           +linebreak         +python3           +visualextra
+cryptv            +lispindent        +quickfix          +viminfo
+cscope            +listcmds          +reltime           +vreplace
+cursorbind        +localmap          +rightleft         +wildignore
+cursorshape       +lua               +ruby              +wildmenu
+dialog_con        +menu              +scrollbind        +windows
+diff              +mksession         +signs             +writebackup
+digraphs          +modify_fname      +smartindent       -X11
-dnd               +mouse             -sound             -xfontset
-ebcdic            -mouseshape        +spell             -xim
+emacs_tags        +mouse_dec         +startuptime       -xpm
+eval              -mouse_gpm         +statusline        -xsmp
+ex_extra          -mouse_jsbterm     -sun_workshop      -xterm_clipboard
+extra_search      +mouse_netterm     +syntax            -xterm_save
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
 2nd user vimrc file: "~/.vim/vimrc"
      user exrc file: "$HOME/.exrc"
       defaults file: "$VIMRUNTIME/defaults.vim"
  fall-back for $VIM: "/opt/homebrew/share/vim"
Linking: clang -L. -fstack-protector-strong -L/opt/homebrew/lib -L/opt/homebrew/opt/libyaml/lib -L/opt/homebrew/opt/openssl@1.1/lib -L/opt/homebrew/opt/readline/lib -o vim -lm -lncurses -liconv -lintl -framework AppKit -L/opt/homebrew/opt/lua/lib -llua5.4 -mmacosx-version-min=11.2 -fstack-protector-strong -L/opt/homebrew/Cellar/perl/5.32.1_1/lib/perl5/5.32.1/darwin-thread-multi-2level/CORE -lperl -L/opt/homebrew/opt/python@3.9/Frameworks/Python.framework/Versions/3.9/lib/python3.9/config-3.9-darwin -lpython3.9 -framework CoreFoundation -lruby.3.0 -L/opt/homebrew/Cellar/ruby/3.0.1/lib 
  • 1
    Likely related: vi.stackexchange.com/q/31262/10604
    – D. Ben Knoble
    May 13 '21 at 23:23
  • Which terminal are you using, iTerm2 or the native terminal? Do you have trouble getting other terminal apps to use IM too? Have you consider trying to get it to work on GVim or MacVim instead?
    – filbranden
    May 13 '21 at 23:43
  • 1
    @filbranden I just noticed the shortcut doesn't work also on terminal. So the problem is not specific to vim but specific to the terminal, maybe? I'm using the default terminal on mac. I haven't tried other terminals nor other versions of vim but I'll do that.
    – ynn
    May 14 '21 at 0:01
  • @D.BenKnoble Thank you for your suggestion but didn't work.
    – ynn
    May 14 '21 at 0:11
  • There's a very large Vim community in Japan, but not sure if many Japanese users hang out here... Check out vim-jp.org, github.com/vim-jp, youtube.com/c/Vim-jpOrg, twitter.com/vim_jp, etc. If you do find a good answer, please circle back and post a self-answer here, that would be really awesome!
    – filbranden
    May 14 '21 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.