11

I'm on Arch Linux with alacritty, zsh and neovim nightly (NVIM v0.5.0-dev+1069-g02a966386). I've read several posts on disabling the mouse in vim including 13566 and have put the following in my init.vim

" disable mouse
map <ScrollWheelUp> <nop>
map <S-ScrollWheelUp> <nop>
map <C-ScrollWheelUp> <nop>
map <ScrollWheelDown> <nop>
map <S-ScrollWheelDown> <nop>
map <C-ScrollWheelDown> <nop>
map <ScrollWheelLeft> <nop>
map <S-ScrollWheelLeft> <nop>
map <C-ScrollWheelLeft> <nop>
map <ScrollWheelRight> <nop>
map <S-ScrollWheelRight> <nop>
map <C-ScrollWheelRight> <nop>
set mouse=

I've also tried set ttymouse= but nvim complains E518: Unknown option: ttymouse=.

With the above settings, the cursor still moves when I scroll.

How do I fully disable mouse actions in neovim?

1 Answer 1

11

For those googling, the option name in neovim is just mouse:

set mouse=
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.