1

I just started using Unite and I noticed that searching with file_rec doesn't return my vimrc. I've tried reinstalling Unite, clearing its cache with and a few other things but nothing makes this file show up. Searching with the file option does return my vimrc though.

To be complete, my vimrc is symlinked from another folder (called .dotfiles). If I cd into .dotfiles, open Vim, activate Unite, and search with the file_rec option my vimrc will not show up.

I'm running Windows 8.1 in Cygwin if it might matter. Thanks for any help.

The problem still occurs with a minimal vimrc

call plug#begin()
Plug 'https://github.com/Shougo/unite.vim'
call plug#end()

call unite#filters#matcher_default#use(['matcher_fuzzy'])
call unite#custom#default_action('file', 'tabopen')
call unite#custom#default_action('buffer', 'tabopen')
call unite#custom#default_action('tab', 'tabopen')
call unite#custom#default_action('jump_list', 'tabopen')

nnoremap <C-P> :Unite -start-insert file_rec<CR>
nnoremap <C-B> :Unite -start-insert buffer<CR>
  • It's common to disable the following of symbolic links when searching for files recursively to avoid infinite loops. Imagine ln -s . self – tommcdo Apr 28 '15 at 1:18
  • I have several other dotfiles that are symlinked in a similar manner in the same location and all of those show up. The symlinks are in ~ and the actual files are in ~/.dotfiles. I use Unite from ~/.dotfiles. – Chad Paradis Apr 28 '15 at 1:21
0

I believe this turned out to be a permission error with Cygwin. Deleting and recloning my dotfiles from github seems to have fixed the problem.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.