0

I've installed vimspector. When I type :Vim in the command & hit tab, I get all matched autocomplete suggestion like VimspectorAbortInstall, VimspectorEval, Vim.... etc.

I'm tired to iterate that long matched list one by one to select the correct command. How to make neovim just suggest the Vimspector sub-word so I can just type the rest of command that I want to run?

1
1

It is likely that there are other commands that start with :Vim but not :Vimspector that are being offered in the completion, hence why it stops there.

Natively, vim offers the :VimballList command. You can see with :h :VimballList that this comes from the pi_vimball standard plugin. That page will tell you that if you do not wish to use this plugin you can disable it with the following in your .vimrc:

let g:loaded_vimballPlugin = 1
let g:loaded_vimball = 1

Native vim also offers the :Vimuntar command. :h :Vimuntar shows that this is from the pi_tar standard plugin which can be disabled with the following in your vimrc:

let g:loaded_tarPlugin = 1
let g:loaded_tar = 1

If, for whatever reason, you still wanted to use other features of those plugins but not those commands, although they are bundled with vim they are technically "user-defined" commands and can be deleted with :delcommand VimballList and :delcommand Vimuntar.

Note that I use vim, not neovim, so cannot tell if there are other commands also offered in neovim's completion menu that you would need to investigate in a similar fashion.

0

Make a mapping, say,

nnoremap <leader>v :Vimspector

Note that it doesn’t end with a space or return or anything, so when you type the mapped characters you’ll be waiting at a partially filled prompt.

You could even add <C-z> (assuming that’s what your wildcharm is) to trigger completion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.