I suspect this is the same in vim as well, but fwiw I'm actually using nvim.

For a long time I've used set mouse=a so I can choose to navigate my file with the mouse, if I so wish.

What I've never noticed today is that if I click into PuTTY with nvim open, is that this has the side effect of automatically entering visual mode. Normally I don't click on PuTTY very much, but just alt-tab to it, but today I have a lot of windows open, and have connected two external screens, and I find myself clicking, and then having issues as I'm suddenly in visual mode when I don't expect to be.

If I remove set mouse=a (or do set mouse-=a) then this behaviour goes away, but I can no longer move the cursor within nvim with the mouse.

Any bright ideas?

Thank you!

  • Just a guess but might be fixable with a putty setting. See settings in Window>Selection section, for example.
    – B Layer
    Commented Mar 17, 2021 at 14:45
  • I can't really see anything there that would be relevant, and I've never changed (I think) any of those settings from stock.
    – Codemonkey
    Commented Mar 17, 2021 at 17:06
  • Well, not changing settings isn't really relevant if you never clicked windows before...same as with neovim, no? BTW, you ought to try it with Vim and note the result as that could be a valuable data point.
    – B Layer
    Commented Mar 17, 2021 at 17:15
  • Hard to say... trying to check, but when I run vim I can't get the mouse to work at all; I type :set mouse=a and it makes no difference, clicking doesn't do anything. Not sure what I'm missing there...
    – Codemonkey
    Commented Mar 17, 2021 at 17:20
  • As for not changing settings - my point was I'm using the software in a very typical way - I don't feel I've done something unusual/peculiar, so thought this might be a common/known issue!
    – Codemonkey
    Commented Mar 17, 2021 at 17:21


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.