0

I am using zsh on Mac and noticed that whenever I start vim, it always starts in insert mode. I use vim to inspect files more often than to edit. I tried adding set noinsertmode but it didn't have any effect.

How can I switch to normal mode upon start?

4
  • 5
    I'm voting to close that as a duplicate of How do I debug my vimrc file? because vim default behavior is to start in insert mode and what you are observing is most likely the effect of a configuration you added to your vimrc. Or -but this is less likely- a consequence of how you invoke vim (maybe a parameter you give it or a bash alias you created and didn't realized it would have this side effect) – statox Mar 9 at 12:38
  • 3
    I guess this is a typo: vim default behavior is to start in normal mode – okket Mar 9 at 12:54
  • 2
    Welcome to Vi and Vim! As @statox says, this isn't default, and the debug link might help you find the issue. In particular, if this isn't happening with, say, vim -u NONE or vim -u DEFAULTS or vim --clean, you probably have a configuration issue. It could also be a parameter or alias, as mentioned. – D. Ben Knoble Mar 9 at 14:41
  • 1
    @D.BenKnoble True, if I switch off the plugins, vim starts in NORMAL mode. Thanks! – minerals Mar 9 at 14:51