0

You can see the behaviour on this streamable video. As you can see, I'm just going up and down and text gets redrawn as I do that.

It would be very impractical to call :redraw function manually every time I use fzf-complete-line.

I tried writing wrapper functions that call fzf#vim#complete#line and redraw after that, but to no avail. I also tried modifying source code for the fzf#vim#complete#line function by calling redraw right after it, but it didn't help either.

1
  • 2
    Welcome to Vi and Vim! I’m not sure I see the question in your post. Perhaps you’ll have better luck filling a bug report with the fzf maintainers? – D. Ben Knoble Feb 26 at 14:06
0

I honestly didn’t see the issue in the video.

However, have you tried setting:

set lazyredraw

It buffers the screen updates, which might help your situation.

5
  • How do you not see it? After inserting line, bunch of lines get redrawn when I hover over them. – Fedja Mladenovic Feb 27 at 16:51
  • I am on mobile. It’s possible I just couldn’t see it on my screen. Have you tried setting lazyredraw? – Risky_91 Feb 27 at 17:16
  • Welcome to Vi and Vim! – D. Ben Knoble Feb 27 at 19:34
  • @Risky_91 yes, i did. nothing changes. – Fedja Mladenovic Feb 28 at 14:40
  • Try :redraw! instead as well. That clears the screen first then redraws it. – Risky_91 Feb 28 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.