0

I'm on Windows using gVim, Vim version: 8.2.2003. I get a warning pop-up with the following error message:

Some language features are not available. To access all features, enable [strictTemplates](https://angular.io/guide/angular-compiler-options#stricttemplates) in [angularCompilerOptions](https://angular.io/guide/angular-compiler-options).

1Open tsconfig.json

Is there a way to suppress this error message?

It is particularly annoying as it will show multiple times throughout a session as the background process that triggers it runs.

I know this is being generated by the coc-angular extension for the coc.nvim plugin. I know I could also enable the strictTemplates compiler option that is suggested. However, there are a number of files that fail the strict checks so I'd like to leave that setting off for the time being. I'm fine with a coc specific or general solution to this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.