0

The system on which I do a lot of my work just "upgraded" and among other changes, powerline is now installed and turned on by default for all vim users. I... really don't like it. It's buggy in my terminals and rather than fix it I'd prefer to just turn it off.

But I can't? From the various :help screens, it looks like I should just be able to take it out of the statusline setting and it'd go back to defaults. Right now if I :se stl it shows me:

statusline=%!py3eval('powerline.statusline(1)')

But if I run

:se stl=

(i.e. set it to empty), nothing changes. In fact, no matter what I put after the equals there to set the statusline to something else, if I check the value of the option, it's still the same call, to evaluate a powerline call through python. To verify that I'm not completely forgetting how to use vim, I tried changing and resetting and blanking out the fileformat option and it did just as I expected. It's just statusline that won't change when I change it.

So somehow the statusline option is absolutely locked and unchangeable on this system. Where would I even look to fix that?

The local vim version is 8.0.1568, running on openSUSE Leap 15.2. powerline doesn't seem to have a __VERSION__ field but pip freeze is telling me it's version 2.6.

1
  • Maybe there are some autocommands in place. You could try :verbose set statusline? and also see what modifications to the system vim config have been made. Also :help powerline may have useful results if whatever it is ships with docs (try :helptags ALL first).
    – D. Ben Knoble
    Feb 15 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.