1

I've been trying to get the vim-pandoc plugin to play nice with markdown nvim, and have not been successful in finding help so far. The trouble seems to be that vim-pandoc sets markdown files to be recognised by vim as pandoc files which prevents the vim-markdown plugin from running syntax highlighting etc. In any case, as soon as install the vim-pandoc plugin, my syntax highlighting goes out the door in markdown. If only I could get vim-pandoc not to do this, I'd be all set. It looks like this is the way to achieve this result:

let g:pandoc#filetypes#pandoc_markdown = 0

By default, the above is set to 1, but setting it to 0 has not helped. If anyone has any ideas about how to proceed, I'd greatly appreciate the help. The issue I'm having has also been raised in the vim-pandoc GitHub issue 70 and issue 382, but none of the suggestions there seem to help. What I've settled for instead is using the vim-pandoc-syntax plugin as well, simply accepting that all the other markdown plugins won't work as expected. One feature I really miss is where you have a list and it auto generates the next bullet point etc., when you create a new line in the list. The vim-pandoc-syntax plugin which is supposed to pair with vim-pandoc does not have this set be default, and I'm not sure how to get it to reproduce the autogenerate list item functionality that I used to have. I've even considered adding this bullets plugin, but it feels like the better option would be to prevent vim-pandoc from getting in the way of my original markdown plugin which was working great. Any help would be greatly appreciated!

1
  • 2
    Welcome to Vi and Vim! Have you tried putting the :let before :filetype on? Re: bullets, have a look at :help 'formatoptions' and :help 'formatlistpat'
    – D. Ben Knoble
    Feb 1 '21 at 20:29
0

Correct. The setting g:pandoc#modules#enabled can mess with your keybindings, and many other things. Passing an empty list helped on my case.

let g:pandoc#modules#enabled = []

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.