0

I'm using Neovim and my init.vim has a quick save mapping as below

nmap <leader>w :w!<cr>

Since i installed vim-wiki, there's a noticeable delay in the execution of w because of vim-wiki mapping ww.

I tried removing the mapping with

nunmap <leader>ww

and also tried

nmap <leader>vw <leader>ww

but the delay persists. I use the quick save quite often so the delay is a bit annoying.

Is there a way to remove or remap it to

nmap <leader>vw :VimwikiIndex
2
0

Two options:

  • map to the <Plug> sequence for the command you need yourself (vimwiki won't create the mappings if it detects that you already did)
" :help vimwiki-global-mappings
" :help vimwiki-local-mappings
nmap <leader>vw <Plug>VimwikiIndex

I don't like this solution because there are a lot of <leader>w mappings, and any one of them is going to conflict with yours and cause a delay.

  • Change vimwiki's prefix:
" :help g:vimwiki_map_prefix
let g:vimwiki_map_prefix = '<leader>v'

A third option that requires more work is to build your own wiki system. My plugin wiki-md attempts to make this easy by leveraging a bunch of vim builtins. More info provided if desired, but I will note that wiki-md provides more of a skeleton on which you build your own features; it doesn't come with everything out of the box that something like vimwiki does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.