1

I am currently running a few plugins (git gutter, fugitive), and it appears that one of them has overridden the behavior of Control-W,= so that instead of making vertically split windows have equal height, it maximizes the height of the top one.

I would like to restore the original behavior, so I tried to look for the mapping in the output of :map and :nmap, but I did not see it.

Is there a different place to look for figuring out how to undo this mapping (or some option that is changing this behavior)?

2
  • Are you sure you’re not pressing <C-w>_, which might be similar to your equal key? That would maximize height I believe. – D. Ben Knoble Jan 22 at 12:39
  • Yup, I'm sure. Because vim -u None does not exhibit the bad behavior. – merlin2011 Jan 22 at 23:31
1

I just did a binary search on my vimrc and plugins and discovered the following line in my vimrc that caused this strange behavior:

set laststatus=3

When I commented this out, the silly behavior went away.

1
  • Indeed. And behavior is really odd under that setting. Documentation suggests it should only be set to 0, 1 or 2, so wondering why it behaves so oddly under value 3... (Perhaps a mix of behavior of 1 and 2?) Looks like a bug to me, consider reporting it upstream. – filbranden Feb 21 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.