0

When I'm coding, I like to have neovim window up and command line window down to run my code on the screen. When I save a neovim file and divide the screen into two horizontally using tmux, the neovim window rolls up automatically instead of staying still. This doesn't happen when using vim with tmux, so I thought some specific configuration in init.vim file that is used only for neovim was causing this behavior, but I couldn't find any configuration that leads to this. I even removed the init.vim file to see if that solves this, but neovim window still rolled up automatically when I divided the screen, which means some specific default configuration for neovim is causing this behavior. I'm using neovim version 0.4.3 with tmux version 3.1b.

2
  • Do you mean the text scrolls up when the tmux pane is resized? Does it have something to do with the cursor position? NeoVim is scrolling the buffer so that the text under the cursor will stay displayed in the smaller screen space it has? Is that possibly the case? There's also 'scrolloff', try :set scrolloff=0 and see if that makes a difference. You can also check :verbose set scrolloff? in both NeoVim and Vim to see if there's a difference there...
    – filbranden
    Commented Dec 27, 2020 at 18:52
  • The text scrolls up when I divide the tmux pane horizontally into two. It has nothing to do with the cursor position. scrolloff had no effect and scrolling is an unknown option.
    – tet
    Commented Dec 28, 2020 at 12:13

1 Answer 1

0

I'm not using neovim but, if it can help, you can use the built-in terminal.

in exemple:

:split term://bash

Will open the terminal (with the bash shell) in the bottom.

You can get more information about the usage with :help terminal-input and there is also a tutorial here if you want

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.