0

I am a newbie in vim and I added set clipboard=unnamedplus in .vimrc but doesn't work , in my previous os, I had the same problem and I fixed it by reinstalling vim using source and adding some extra argument to ./configure but now I forgot those arguments, do you know those arguments?

6
  • If you're on *nix it sounds like you are referring to the need to build the GUI (vim-gtk3, vim-gtk, vim-gnome) branch. Clipboards are a GUI feature so the terminal versions of Vim don't have support for them. – B Layer Nov 20 '20 at 23:33
  • @BLayer yes I'm on Linux, and I used that and that worked on the terminal version I'm pretty sure – Mahdi mehrabi Nov 20 '20 at 23:37
  • If you're sure you have the right codebase then maybe you're referring to building --with-features=huge. See: vimhelp.org/vim_faq.txt.html#faq-35.10 – B Layer Nov 20 '20 at 23:39
  • Note that I didn't say you couldn't use clipboards with terminal . I said you need a GUI codebase .... that will have the required libraries. – B Layer Nov 20 '20 at 23:42
  • @BLayer thank you but I think --with-features=huge is the default and I installed my current vim with passing that flag too – Mahdi mehrabi Nov 21 '20 at 0:02
0

first

 git clone https://github.com/vim/vim.git

 cd vim/src

and these are the flags for installing vim and enabling GUI features contain clipboard support

./configure --enable-gui=auto --enable-gtk2-check --with-x --prefix=/usr

then make && sudo make install

note: I did not pass --with-features=huge because its the default

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.