I have the following vimrc.

I noticed that there is a single line that's blowing up my usage of the FZF :BTags command:

filetype plugin indent on

Ie when I run the command :BTags I get this error

Error running cat '/var/folders/1b/3wwzdg214cz57k2nccl_9d5c0000gn/T/vxOBh5q/14'|'/Users/abdullah/.vim/bundle/fzf/bin/fzf'  '--layout=reverse-list' '
-m' '-d' '\t' '--with-nth' '1,4..' '-n' '1' '--prompt' 'BTags> ' '--query' '' --expect=ctrl-v,ctrl-x,ctrl-t --height=10 > /var/folders/1b/3wwzdg214c

However if I remove it, the :Btags command works but all my syntax highlighting is gone. What do I do?

  • What do you mean by "blowing up my usage"? What exactly happens when you do :BTags? Nov 10 '20 at 16:54
  • Updated the question
    – abbood
    Nov 10 '20 at 16:58
  • that line has to come after the vundle stuff
    – D. Ben Knoble
    Nov 10 '20 at 19:58
  • @D.BenKnoble i put it after, i still get that error
    – abbood
    Nov 10 '20 at 20:05

I solved this problem by using neovim instead of vim. Neovim gave me a better error message:

unkown option: --layout=reverse-list

enter image description here

from there i realized that I was using an outdated version of fzf, and neovim updated and problem solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.