0

I have only the Working directory or document and Active process name preferences checked for Terminal window titles. Then in VIM I use a custom titlestring. However, the title bar is displayed as "<directory vim was executed in> — <custom titlestring> — vim". What I would like to do is remove the directory part as well as the trailing vim part, but if I uncheck those options in the Terminal preferences, then it applies to every Terminal window, and the result is all non-Vim terminal windows just display "Terminal" in the title bar.

Is there a way to make it so that Vim can override the default Terminal title bar preferences and have the title bar only display titlestring?

2
  • Can we know what terminal emulator it is and what is your titlestring? I believe it simply wraps the title string in <directory> and - <command>.
    – Quasímodo
    Oct 28 '20 at 21:00
  • @Quasímodo What is the relevance of the specific type of terminal emulator? I'm using macOS's 'Terminal' application, is that not specific enough? My titlestring is equal to %f. Also it doesn't simply do that. What is displayed in the title bar is dependent on your terminal window preferences, and your Vim title and titlestring settings; with other Vim settings potentially affecting it as well, but from those I have seen, none enabling you to discard the strings injected into the titlebar by the Terminal application itself.
    – shoe
    Oct 28 '20 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.