0

I have installed vim-pandoc, as suggested here. When I open Vim in the terminal I get only 'Omni completion (^O^N^P) Pattern not found' errors. echo pandoc#bibliographies#Find_Bibliographies() returns a list of biblatex files, as expected.

One very strange thing is that if I open GVim and write a new .md file, completion works. But not if I then open the same file either from the terminal or with GVim.

I raised the issue here.

I have Vim 8.2.716 on Ubuntu 20.10.

Here is my .vimrc:

set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'

" pandoc
Plugin 'vim-pandoc/vim-pandoc'
Plugin 'vim-pandoc/vim-pandoc-syntax'
Plugin 'vim-pandoc/vim-pandoc-after'

" better LaTeX conceal, which pandoc will inherit
Plugin 'KeitaNakamura/tex-conceal.vim'

" All of your Plugins must be added before the following line
call vundle#end()            " required
filetype plugin indent on    " required
" To ignore plugin indent changes, instead use:
"filetype plugin on
"
" Brief help
" :PluginList       - lists configured plugins
" :PluginInstall    - installs plugins; append `!` to update or just :PluginUpdate
" :PluginSearch foo - searches for foo; append `!` to refresh local cache
" :PluginClean      - confirms removal of unused plugins; append `!` to auto-approve removal
"
" see :h vundle for more details or wiki for FAQ
" Put your non-Plugin stuff after this line

" UK spelling for Markdown
autocmd FileType markdown setlocal spell spelllang=en_gb

" recognise .md as Markdown
autocmd BufNewFile,BufReadPost *.md set filetype=markdown.pandoc

" case insensitive search
set ignorecase

" tabs are 4 spaces
set expandtab
set shiftwidth=4
set softtabstop=4

" omnicompletion
set omnifunc=syntaxcomplete#Complete
set completeopt=menu,menuone

" conceal settings
set conceallevel=2
let g:tex_conceal="abdgm"

" look for bibliographies
let g:pandoc#biblio#sources="l"

" omnicomplete
set omnifunc=syntaxcomplete#Complete

What could be causing this?

6
  • 4
    this is a problem of that plugin. So the issue tracker is the right place to discuss this. Oct 26, 2020 at 20:49
  • @ChristianBrabandt This doesn't happen to everyone who uses the plugin. So, it's a problem of the interaction between the plugin and my setup.
    – twsh
    Oct 27, 2020 at 8:51
  • 1
    How to debug my vimrc
    – D. Ben Knoble
    Oct 27, 2020 at 13:17
  • @D.BenKnoble I loaded just vim-pandoc. It makes no difference. (Assuming I followed the instructions correctly, of course.)
    – twsh
    Oct 27, 2020 at 14:08
  • 1
    @r0berts I now use Neovim and a different config file. And it works. But I'm not sure how to draw any helpful conclusions from that.
    – twsh
    Jan 26 at 17:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.