0

I use 999dd as a goto command before pasting/overwriting the entire contents from the clipboard. For some reason this is not working (at all) on a specific ubuntu machine.

Why would this not work be working? Is there a vim setting required (or that should be removed) to get this going?

Note: I do realize that :1,$d (go to command mode then do 1,$d) will also work. I'm just wondering about this difference in behavior.

Update I am seeing some extraneous text intermittently:

debug2: channel 0: window 994746 sent adjust 53830

That text is actually ending up dumped into the editor buffer. What is that all about?

OK i see this reference https://stackoverflow.com/questions/40987330/debug2-channel-x-window-number-sent-adjust-number-2

This message is the result of connecting to a machine using ssh with the -vv flag turned on. In my case I'd used -vv to diagnose why a client machine was rejecting my connection and had forgotten to close and reopen the session without debug flags after diagnosing the problem.

I am using an alias for connecting via ssh: must have that in there. I will remove it and see if it also fixes the original issue.

3
  • 1
    Start vim with --clean and try it. That'll give you default config and disable plugins.
    – B Layer
    Oct 26 '20 at 2:01
  • 1
    Completely unrelated, but :%d is easier to type (at least for me)
    – D. Ben Knoble
    Oct 26 '20 at 12:05
  • 1
    @D.BenKnoble duly noted: I'll have to unlearn the muscle memory and go for that one. Oct 26 '20 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.