0

I'm using xfce4-terminal version 0.8.9.2. I have installed FZF.vim plugin and whenever I do either an :FZF search or an :Rg search in vim, I cannot select all the matches with Alt + a or deselect all the matches with Alt + d. When I press Alt + a, the xfce-4 terminal Tab menu opens up. When I press Alt + d, nothing happens.

Apparently in xfce-4 terminal, I have to press Esc + a to select all matches or Esc + d to deselect all matches. This is quite annoying since if I accidentally press just the Esc key without holding it down, it will cancel the command (':FZF' or ':Rg PATTERN' in this case).

How can I remap the default terminal key combinations for this?

I've tried to put the following in my .vimrc but it doesn't work:

tnoremap <A-a> <Esc>a
tnoremap <A-d> <Esc>d

Neither does this:

tnoremap <M-a> <Esc>a
tnoremap <M-d> <Esc>d

Nor this:

execute "set <M-a>=\ea" 
tnoremap <M-a> <Esc>a
execute "set <M-d>=\ed" 
tnoremap <M-d> <Esc>d

1
  • When I press Alt + a, the xfce-4 terminal Tab menu opens up. Disable all menu access keys. In xfce4-terminal 0.6.3, you can do so by right-clicking on the terminal, then select the Advanced tab, and untick the Disable all menu access keys (such as Alt+f) box. – user938271 Oct 24 '20 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.