1

AFAIK vimwiki's markdown syntax doesn't emphasize in any way blockquotes. I mean:

> This is a quote

is presented instead as simple text. For reading notes it can be confusing. So, how do you highlight both the > and the quote?

  • I'm pretty sure https://github.com/sheerun/vim-polyglot has highlighting for block quotes, if that's an option. – Jake Grossman Oct 17 at 14:13
  • I've tried several colorschemes, both dark and light versions, and not a single one highlights either the > nor the whole block of text, @D.BenKnoble – Ludenticus Oct 17 at 17:29
  • I found no definition for markdownBlockquote in https://github.com/blueshirts/darcula/blob/master/colors/darcula.vim. It has only extra headers highlighting. – Ludenticus Oct 17 at 18:32
  • I realize that vimwiki's markdown syntax doesn't highlight it, and it's not affected by `markdownBlockquote' settings. I rephrased the question. – Ludenticus Oct 18 at 15:54
  • 1
    @Ludenticus dracula =/= darcula, but I'll delete my comment since it's markdown specific – D. Ben Knoble Oct 18 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.