2

I have a problem that sometimes happens when I do type in Neovim. It does not register keys or mouse clicks correctly, which causes me to restart the iTerm session and rescue the working file with .swp.

Sorry for the not so clear explanation, but I have no idea how to describe it! Though, I have recorded a video of it: https://www.youtube.com/watch?v=be0BzIRafd4

Why is this happening? Am I pressing some key combination I am not aware that cause this?

Nvim Dotfiles: https://github.com/ogirginc/dotfiles/tree/master/nvim

4
  • Interesting issue. Also intriguing that your Vim command line flickers with ... on every keystroke. And how Esc or Ctrl+C or Ctrl+O don't work either... Do you have any suspicious plug-ins loaded? I wonder if this will also happen under nvim --clean, but since you're not sure of how to reproduce it, perhaps hard to tell... There's also nvim -w scriptout to log your keystrokes into a scriptout file, perhaps you could use that so you can inspect it later to see what happened just before the problem started?
    – filbranden
    Sep 16, 2020 at 12:19
  • Any mappings of esc?
    – D. Ben Knoble
    Sep 16, 2020 at 12:28
  • @Ben the odd part is that the other typical ways of leaving normal mode (<C-C> or <C-O> for a one-off) aren't working either... I think I've seen a similar question recently, let me see if I can find it.
    – filbranden
    Sep 16, 2020 at 15:21
  • 2
    possible duplicate of vi.stackexchange.com/q/26816/71 and vi.stackexchange.com/q/26418/71 I believe you are still in bracketed-paste-mode. Most likely this is a bug of neovim. Sep 17, 2020 at 7:13

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.