0

In my vimrc, for vim-latex-suite I have used (as described here)

  let g:Tex_FoldedMisc = 'preamble,!!!'

with the expectation that it will fold the text inside

\noindent{%!!!
....
%!!!

I won't like to use the default <<<, as for my other setup, << is mapped to <>, and hence trying !!!.

But this is not working. Am I missing something?

1

As mentioned in the documentation for Tex_FoldedMisc that you linked to:

Unlike the other Tex_FoldedXXXX variables, the words in this setting are limited to take values from the following list.

And while the list includes preamble and <<<, it doesn't include other triplets of symbols such as !!!.

The documentation seems quite explicit that <<< (with the corresponding >>>) is the only set actually supported by this option, using a different symbol will just not work.

1
  • 1
    oh...sure! its even more explicit with "Any other words in the Tex_FoldedMisc setting are silently ignored." Somehow I missed it, with the first line as default value is.
    – BaRud
    Sep 14 '20 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.