0

I have installed SpaceVim. My init.toml file looks as follows:

#=============================================================================
# dark_powered.toml --- dark powered configuration example for SpaceVim
# Copyright (c) 2016-2017 Wang Shidong & Contributors
# Author: Wang Shidong < wsdjeg at 163.com >
# URL: https://spacevim.org
# License: GPLv3
#=============================================================================

# All SpaceVim option below [option] section
[options]
    # set spacevim theme. by default colorscheme layer is not loaded,
    # if you want to use more colorscheme, please load the colorscheme
    # layer
    colorscheme = "gruvbox"
    colorscheme_bg = "dark"
    # Disable guicolors in basic mode, many terminal do not support 24bit
    # true colors
    enable_guicolors = true
    # Disable statusline separator, if you want to use other value, please
    # install nerd fonts
    statusline_separator = "arrow"
    statusline_inactive_separator = "arrow"
    buffer_index_type = 4
    enable_tabline_filetype_icon = true
    enable_statusline_mode = false

# Enable autocomplete layer
[[layers]]
name = 'autocomplete'
auto_completion_return_key_behavior = "complete"
auto_completion_tab_key_behavior = "smart"

[[layers]]
name = 'shell'
default_position = 'top'
default_height = 30

[[layers]]
  name = "lang#c"

[options]
  colorscheme = "desert"
  colorscheme_bg = "dark"

[options]
    autocomplete_method = "coc"

Now, when I open a blank c++ file, I get the following:

Issue

I can't seem to figure this out as I just installed VIM. Could someone kindly explain how to fix this?

EDIT

I am using Mac OS, I installed neovim using brew install neovim. This works fine.

I then installed spacevim: curl -sLf https://spacevim.org/install.sh | bash

The instructions for this install command are here: Link

Running the :version command inside nvim gives this:

:version                                                                                                                                              
NVIM v0.4.4
Build type: Release
LuaJIT 2.0.5
Compilation: /usr/bin/clang -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -DNDEBUG -DMIN_LOG_LEVEL=3 -Wall -Wextra -pedantic -Wno-unused-parameter -Wstrict-prototypes
 -std=gnu99 -Wshadow -Wconversion -Wmissing-prototypes -Wimplicit-fallthrough -Wvla -fstack-protector-strong -fno-common -fdiagnostics-color=auto -DINCLUDE_GE
NERATED_DECLARATIONS -D_GNU_SOURCE -DNVIM_MSGPACK_HAS_FLOAT32 -DNVIM_UNIBI_HAS_VAR_FROM -I/tmp/neovim-20200808-89283-1us0ytm/neovim-0.4.4/build/config -I/tmp/
neovim-20200808-89283-1us0ytm/neovim-0.4.4/src -I/usr/local/include -I/tmp/neovim-20200808-89283-1us0ytm/neovim-0.4.4/deps-build/include -I/Library/Developer/
CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include -I/usr/local/opt/gettext/include -I/tmp/neovim-20200808-89283-1us0ytm/neovim-0.4.4/build/src/nvim/auto -I/tm
p/neovim-20200808-89283-1us0ytm/neovim-0.4.4/build/include
Compiled by brew@Catalina

Features: +acl +iconv +tui
See ":help feature-compile"

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/local/Cellar/neovim/0.4.4/share/nvim"

Run :checkhealth for more info

EDIT2

enter image description here

  • Welcome to Vi and Vim! Take a look at vim --version or equivalently output of :version from inside Vim. Please edit the question to include that information in your question. Looks like you're on Mac OS. How did you install Vim there? That's probably relevant here... – filbranden Aug 20 '20 at 22:48
  • Thanks @filbranden, I have edited the original que. I installed neovim, then I installed spacevim. I had vim already on my mac by default I think. – finite_diffidence Aug 20 '20 at 22:52
  • Try :checkhealth? See also github.com/neovim/neovim/wiki/FAQ#python-support-isnt-working – filbranden Aug 20 '20 at 23:05
  • 1
    Thanks, from the looks of it looks like I will need to install neovim for pip3 – finite_diffidence Aug 20 '20 at 23:09
  • 1
    If you figure it out, please post an answer with what fixed it for you! – filbranden Aug 20 '20 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.