1

Basically title. Text inside \textit and \textbf is correctly formatted in italics and bold, but if I nest one inside the other, the text takes the formatting of the outer command, as shown here

enter image description here

the bold-italic highlight group does exist and it's defined by

:hi texBoldItalStyle
texBoldItalStyle xxx cterm=bold,italic gui=bold,italic
Press ENTER or type command to continue

Can anyone confirm this is what they get as well?

Edit: I'm on macOS, running neovim inside alacritty with termguicolors set, and I'm using Iosevka nerd font which has a bold-italic typeface.

15
  • 1
    The problem is not the terminal, I know that because a) bold-italic works fine in markdown, b) setting the highlight group to something like hi texBoldItalStyle guifg=#00ff00 has no effect, which I think means the text inside both \textit and \textbf is not recognised as belonging to that particular highlight group. – noibe Aug 18 '20 at 13:43
  • 1
    I'm already using vimtex. I also have let g:tex_conceal = '' in my init.vim. – noibe Aug 18 '20 at 17:04
  • 1
    I've already filed the issue, it's the most recent one on the vimtex's github page. Once I get an answer there I'm going to update my question and hopefully post an answer. – noibe Aug 18 '20 at 17:17
  • 1
    The issue has been resolved upstream. Should I delete the question? – noibe Aug 21 '20 at 14:21
  • 1
    Right, I've been using vimtex the whole time and I forgot that the default syntax file gets it wrong too. I'll post an answer later. – noibe Aug 21 '20 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.