2

If I run from the vim terminal

:! zathura foo.pdf

It opens foo on top of the terminal and when I exit I go back to the vim file. If instead I try:

:! zathura --fork foo.pdf

The intended behaviour is to open the pdf in a new window while still having the vim file open. It doesn't open at all. What do I do to fix this and why is it occuring?

3
  • The intended behaviour is to open the pdf in a new window - are you using tiling window manager? Aug 16, 2020 at 17:57
  • I'm using dwm. This is what happens when I run the command on a new terminal. Aug 16, 2020 at 18:01
  • I get the expected behavior with --fork: I can get back to Vim and see the pdf in zathura at the same time. Can you double check if your version of zathura has the --fork option? If you try zathura --fork foo.pdf in a normal shell, does it work correctly?
    – Quasímodo
    Aug 17, 2020 at 21:15

1 Answer 1

-2

I got the solution:

:! st zathura food.pdf
1
  • 1
    Can you please try to improve your answer, perhaps by explaining why this helps in your case (assuming you understand that), or what in your environment makes it work for you (dwm window manager? st terminal?) Can you explain how you got to the conclusion that this is what was missing?
    – filbranden
    Aug 16, 2020 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.