1

I installed the plugin vimtex.
Then I installed the plugin tex-vim (aka Latex suite).
The compilation keybinding (<Leader>ll) from vimtex stopped working, since tex-vim takes over it.
So I removed tex-vim from my list of Plugs and ran :PlugClean (I use vim-plug as my plugin manager).
Now when I press <Leader>ll it says "Unknown function Tex_RunLatex", meaning that the keybinding for the tex-vim command is still present even after I removed tex-vim.
By running :verbose map \ll I can see that the keybinding is set in a file from the ~/.local/share/nvim/view/ directory. Deleting said file does not solve anything: vim simply creates another one when I restart vim.

What to do to stop tex-vim overwriting my keybindings from the grave, and, if possible, how to stop it from overwriting vimtex keybinding while using both plugins?

7
  • 1
    disable whatever plugin you are using that creates a session or view. Then try again (and read :h 'sessionoptions' and remove the options value) Aug 14 '20 at 13:06
  • Or delete the view files, it remove whatever is automatically loading the views
    – D. Ben Knoble
    Aug 14 '20 at 13:17
  • 1
    according to your sessionoptions, it shouldn't save options and mappings. Are you sure that is correct, because it would mean you do not have that problem. The simplest solution is to quit nvim, remove all session and view files and start over again. Also are you sure, you need a session/view management plugin? Aug 14 '20 at 14:49
  • 1
    @ChristianBrabandt I found a plugin that saved my session state, and removing it solved my problem! I used to use it only to save my folds, but that can be accomplished in other ways. Thank you!
    – Soap
    Aug 14 '20 at 14:52
  • 1
    @Soap Please post an answer with your findings! It might help others in the same situation that get to your question while searching for a solution. Thanks!
    – filbranden
    Aug 16 '20 at 14:34
1

The issue was with the "restore-view" plugin. Disabling it solved the issue.

I was only using it for saving my folds. That can be achieved my using :mkview and :loadview.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.