1

I am trying to install themes using V8+ Vim (8.2) on a Windows 10 OS. I first tried following the standard instructions listed on the Dracula theme site here. Unfortunately, the naming conventions for Unix based systems aren't the same as for Windows so I had to do a little research as to how to modify the instructions. So instead of mkdir -p ~/.vim/pack/themes/start I created a directory in home ~/.vimfiles/pack/themes/start. I then cloned the GitHub repository with git clone https://github.com/dracula/vim.git dracula inside of the start directory.

I then modified my vimrc file with packadd! dracula, syntax enable, and colorscheme dracula. I saved and restarted Vim. I confirmed that the colorscheme was set to dracula with the command :colo and double-checked that it was in the list of all color schemes with :color [Space] [Ctrl+D]. Everything looked like it should be working. Unfortunately I could see no evidence that the theme had changed from the default. I can switch to any of the other preinstalled themes such as "blue" or "desert". But I am unable to change to any of the ones I have attempted to add.

Any ideas where I am going wrong? I would have thought that I misnamed my vimfiles directory except that I would not have expected Vim to detect the theme and add it to the list. Any help would be much appreciated.

Vimrc file Screenshot of _vimrc file What it ACTUALLY looks like in Vim What it DOES look like What it SHOULD look like in Vim What is SHOULD look like Scriptnames scriptnames Runtime Path Runtime Path

  • FYI I followed your steps (except using my path to my vim dir) and everything works for me. Did you try it with a stripped down vimrc? That is, nothing but the bare minimum config plus the above...? – B Layer Aug 5 at 22:18
  • I added a screenshot of my (now) minimal vimrc file – Shadow43375 Aug 5 at 22:55
  • 2
    You could try :set t_Co=256 or set termguicolors. That's the last shot for me. – B Layer Aug 5 at 23:44
  • 1
    I wasn't sure whether the theme was actually changing (with all that entails) or if Vim was merely being reporting falsely that it had. In any case :set termguicolors did the trick! Thanks for working through this. – Shadow43375 Aug 6 at 0:59
  • 1
    Hey, maintainer of that theme here—you can set termguicolors if your term supports it, but the theme should fall back on 256 color sequences in a terminal w/o termguicolors. Now, it could be that there’s a mismatch between your terminal emulators palette and draculas, but I’m not sure. Please (a) use text instead of images for reporting scriptnames and runtimepath, (b) add an answer if you’ve solved the problem, and (c) consider opening an issue on our github if you’re still having trouble. – D. Ben Knoble Aug 6 at 14:25
1

The solution that finally worked for me (suggested in comments) was to add the following to my vimrc file:

set termguicolors

Apparently Vim was not using the full range of colors available to it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.