0

I've started using coc for NeoVim and I've setup a highlight for a line with error using the following:

hi CocErrorLine guibg=#ce2c28

However, when the error line has a concealed character, it has a black background.

enter image description here

How can I use the same background color as the line?

This is the current highlight for the Conceal group:

Conceal        xxx ctermfg=109 guifg=#83a598
                   links to phpOperator

If it's not possible, is there a way to disable conceal when a line is highlighted?

4
  • Changing the Conceal highlight would change the background of all conceal characters; similarly, disabling conceal would disable it for the entire window
    – D. Ben Knoble
    Aug 5, 2020 at 16:59
  • @D.BenKnoble So there's no way to fix my problem here?
    – Chin Leung
    Aug 5, 2020 at 17:11
  • I am not aware of one, but there are many others on the site that may have intelligent insights
    – D. Ben Knoble
    Aug 5, 2020 at 17:21
  • Why the down vote?
    – Chin Leung
    Oct 20, 2020 at 18:54

1 Answer 1

0

Use NONE when you don't want override others syntax groups

hi Conceal ctermfg=109 guifg=#83a598 ctermbg=NONE guibg=NONE

1
  • 1
    It's already set to NONE.
    – Chin Leung
    Oct 16, 2020 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.