6

I am trying to build vim from source, especially gvim, to get some of the bug fixes that have been plaguing me in the office repository.

I can compile vim fine but gvim is not being generated due to some library missing. I am sure all I am missing is some -devel packages, but which ones?

The issue is this:

./configure --prefix=$HOME --enable-multibyte --enable-pythoninterp --with-fea
tures=big --enable-gui=gnome2 --with-x=yes
[...]
checking for X... (cached) libraries , headers 
[...]
checking if X11 header files can be found... no
checking --enable-gui argument... no GUI support
[...]

Yet:

; sudo yum install -y libX11-devel
Loaded plugins: fastestmirror, langpacks, priorities, remove-with-leaves
Loading mirror speeds from cached hostfile
 * base: mirror.ox.ac.uk
 * epel: mirror.serverbeheren.nl
 * extras: mirror.econdc.com
 * updates: mirror.ox.ac.uk
Package libX11-devel-1.6.0-2.1.el7.x86_64 already installed and latest version
Nothing to do

Is there a canonical list anywhere?

  • 1
    "due to some library missing" is not a very descriptive error... – Martin Tournoij Mar 20 '15 at 9:20
  • Yeah, you probably need a -devel package, or maybe something else? I don't know since I don't see the error ;-) There is also not a single authorize list, since Vim has many compile-time options which influences this (for example, gVim can use several different toolkits)... The general strategy is to see which one you need from the error, install it, and repeat until it doesn't error out. – Martin Tournoij Mar 20 '15 at 9:27
  • 1
    Shouldn't linux tag be not enough? Compiling process should be the same across different distributions. – kenorb Mar 20 '15 at 11:12
  • @Carpetsmoker I think the issue might be that the OP doesn't know where to look to find such an error. They've pasted the error they can see into their question already. – Rich Mar 20 '15 at 12:07
7

For configuration command you've specified gnome2 as your main GUI (--enable-gui=gnome2), are you sure it's the right one? Or maybe gnome2 is not enough to enable GUI, so try to add extra --enable-gui, --with-x parameters.

You can also configure so your GUI would be detected automatically by --enable-gui=auto.

Also make sure that you have all your dependencies such as build-dep and vim-gtk (sudo yum builddep vim-X11 or sudo apt-get build-dep vim-gtk).

If the problem is still happening, check your config.log which should be generated by your ./configure to check exact details of the failure for GUI section.

See also:

  • 3
    The correct yum command is sudo yum-builddep vim-X11. And this solved my problem. – Sardathrion - Reinstate Monica Mar 20 '15 at 11:42
  • 1
    for me what fixed it is remove auto conf cache and a make clean – Mystic Odin Oct 14 '16 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.