3

I'm trying to use ALE for auto-formatting for one specific language, however it has everything turned on for all languages by default and I can't figure out how to configure it so that it's disabled for everything except what I explicitly tell it to.

I've tried using g:ale_pattern_options, I've tried setting g:ale_enabled = 0 and then setting b:ale_enabled = 1 in the filetype plugin but then it just doesn't run at all.

2
  • 1
    Your approach should work—of course, there was one variable that can control what linters are enabled, and you could use that to disable everything. But i would have tried your approach first... what does ALEInfo say?
    – D. Ben Knoble
    Jul 4, 2020 at 2:17
  • 1
    @D.BenKnoble ALEInfo says g:ale_enabled = 0 (newline) b:ale_enabled = 1 but it doesn't work. I've since read somewhere that disabling ALE globally like that can mess things up, so I'm at a loss.
    – Mason
    Jul 4, 2020 at 23:59

1 Answer 1

1

Use the g:ale_linters_explicit option

https://github.com/dense-analysis/ale/blob/master/doc/ale.txt#L1317

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.