0

I ran npm install -g neovim I get version neovim@4.9.0

If I run nvim --version I get v0.4.3

How do I use the npm installed neovim instance?

  • Well, where does npm install global programs? I imagine you’ll need to adjust your path for that (or just find the executable and invoke it directly) – D. Ben Knoble Jun 27 at 1:39
  • 1
    I believe what you get with npm install neovim is simply the node.js module named neovim, not the editor itself... What's your O.S. and if Linux, what distribution/version? You mentioned three versions of NeoVim installed, what is the third one... Is anything not working as expected, or are you just trying to keep it clean with matching the versions? – filbranden Jun 27 at 11:10
  • I think I've actually got it sorted now. Installed with apt, and it should update with apt too. – Costa Jun 27 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.