0

I am in the process of getting myself to start using neovim instead of vim/vi which has been favorite editor for over 30 years.

For my current use, I need to set keymapping to type characters that have diacritical marks. These are IAST diacritical marks available as keymapping file iast.vim. The keymapping can be switched by typing set keymapping=iast The way these keymappings work is you get gīta by literally typing g-ita. Likewise numerous keyboard shortcuts are present in iast.vim

The keyboard mapping works well in vim, but in neovim it works with a caveat. I have to enter the keys really fast to see the diacritical character show up as expected. This is on a Mac. I have experienced the same behavior using iterm2 or alacritty terminal.

Any tips to resolve this?

  • 3
    Vim and Neovim have different default values for some settings. See :h 'timeout' and all that stuff below. Compare the actual values in both your configs. – Matt Jun 20 at 16:56
1

set timeoutlen=500 resolves this. Thanks Matt.

| improve this answer | |
  • 2
    Please edit your answer and explain why or how timeoutlen=500 is the appropriate resolution. This will greatly help future readers. – D. Ben Knoble Jun 24 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.