0

I tried to add the clang_complete plugin to my vim. https://github.com/xavierd/clang_complete

After I added it, I get a large error page before I can open any C++ file. The autocomplete still does not work. I looked through some old threads and wondered if it could be because I don't have a +python3 on my :version page. I followed the steps here to try to activate python3, but I still have a -python3.

Is this error because of that?

I use a Mac.

Error message looks like this. enter image description here

3
  • 1
    Welcome to Vi and Vim! This could be a python3 error; it’s possible the memory error or name error would be resolved using python 2 instead of python 3. But you’ll probably have better luck discussing with plugin maintainers. Also, for the future, please don’t post images of text
    – D. Ben Knoble
    Commented Jun 5, 2020 at 12:38
  • Which suggestions did you try to get Vim with +python3? Are you using Homebrew? On the Mac it's probably the easiest way to get it working... Make sure you're running the Homebrew binary and not the system one.
    – filbranden
    Commented Jun 5, 2020 at 14:24
  • Also, you cant try coc plugin, which is much easier to setup.
    – Waqar
    Commented Jun 9, 2020 at 8:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.