1

(neovim/vim beginner)

After having ran upgrade homebrew I get error when I run nvim +UpdateRemotePlugins +qall. Anyone here knows how to get over this problem?

Anyone here knows how to get over this problem?

I have done some research now and I post what I find below. I have not solved the problem though. When run I checkhealth I see that nvim doesn't have access to ruby neovim it seems. ruby neovim is installed with brew but when I run gem list neovim is not showing in the list. I can also see that neovim folder is located in ~/.gem/ruby/2.7.0./neovim.

When I run gem environment I can see that /usr/local/opt/ruby/bin is in path and I have also added ~/.gem/ruby/2.7.0. to path as mentionned above, but there is no bin inside the ~/.gem/ruby/2.7.0. dir??

Running npm list -g --depth=0 also shows neovim being installed.

:version

:version
NVIM v0.4.3
Build type: Release
LuaJIT 2.0.5
Compilation: /usr/local/Homebrew/Library/Homebrew/shims/mac/super/clang -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -DNDEBUG -DMIN_LOG_LEVEL=3 -Wall -Wextra -pedantic -Wno-unuse
d-parameter -Wstrict-prototypes -std=gnu99 -Wshadow -Wconversion -Wmissing-prototypes -Wimplicit-fallthrough -Wvla -fstack-protector-strong -fdiagnostics-color=auto -DINCL
UDE_GENERATED_DECLARATIONS -D_GNU_SOURCE -DNVIM_MSGPACK_HAS_FLOAT32 -DNVIM_UNIBI_HAS_VAR_FROM -I/tmp/neovim-20191107-13403-1or2rj3/neovim-0.4.3/build/config -I/tmp/neovim-
20191107-13403-1or2rj3/neovim-0.4.3/src -I/usr/local/include -I/tmp/neovim-20191107-13403-1or2rj3/neovim-0.4.3/deps-build/include -I/usr/local/opt/gettext/include -I/Appli
cations/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include -I/tmp/neovim-20191107-13403-1or2rj3/neovim-0.4.3/build/src/nvim/
auto -I/tmp/neovim-20191107-13403-1or2rj3/neovim-0.4.3/build/include
Compiled by brew@Mojave.local

Features: +acl +iconv +tui
See ":help feature-compile"

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/local/Cellar/neovim/0.4.3/share/nvim"

:checkhealth

## Ruby provider (optional)
  - INFO: Ruby: ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin18]
  - WARNING: `neovim-ruby-host` not found.
    - ADVICE:
      - Run `gem install neovim` to ensure the neovim RubyGem is installed.
      - Run `gem environment` to ensure the gem bin directory is in $PATH.
      - If you are using rvm/rbenv/chruby, try "rehashing".
      - See :help |g:ruby_host_prog| for non-standard gem installations.

:messages

internal/modules/cjs/loader.js:605
    throw err;
    ^
Error: Cannot find module 'neovim'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:603:15)
    at Function.Module._load (internal/modules/cjs/loader.js:529:25)
    at Module.require (internal/modules/cjs/loader.js:657:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Object.<anonymous> (/Users/hjalmarjakobsson/Sites/dotfiles/symlink/config/nvim/plugged/markdown-preview.nvim/app/lib/app/preloadmodules.js:3:16)
    at Module._compile (internal/modules/cjs/loader.js:721:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:732:10)
    at Module.load (internal/modules/cjs/loader.js:620:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:560:12)
    at Function.Module._load (internal/modules/cjs/loader.js:552:3)
5
  • 1
    Neovim is on topic here, no problem. Although I don't think I can be of much help, you could provide the error message in your post. :messages will show it.
    – Biggybi
    Jun 2 '20 at 1:28
  • 1
    I'm not familiar with remote plugins neither but it would also be useful to know the result of :version so that we know which version of neovim you are running as well as which remote plugin you installed.
    – statox
    Jun 2 '20 at 8:19
  • 2
    Hey guys, thanks for replying. I updated OP with more info.
    – molleweide
    Jun 2 '20 at 11:50
  • 1
    The error message suggests the neovim Node.js package is missing, but you say it's installed (perhaps edit the question to also include output of the npm command.) Is it possible that that internal/modules/cjs/loader.js code is not able to find the neovim package for some reason, such as package path configurations perhaps?
    – filbranden
    Jun 2 '20 at 19:48
  • 1
    Thanks for looking at my problem. I solved it and posted the answer.
    – molleweide
    Jun 2 '20 at 20:29
2

I solved the problem by running :PlugUpgrade; now my plugins that I use work. It bugged me mainly because fireNvim stopped working in the web browser. The ruby thing still persists but it is probably not a big deal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.