using macOS, I've colored the Terminal app by importing the Solarized theme but the scripts I write inside the terminal are not displayed in the Solarized theme. :colorscheme="default"

enter image description here

While Solarized looks like this.

I can use :colorscheme TAB to find/use Solarized but it just creates an awful highlight effect:

enter image description here

I've been using my build (vimSimple) for years and this issue has never occurred. The only thing that's changed is I've upgraded to macOS Catalina. These files are just softlinked:

ls -al
lrwxr-xr-x   1 USER staff    32 May 21 14:47 .vim -> /Users/USER/code/vimsimple/vim
-rw-------   1 USER staff 26249 May 27 12:15 .viminfo
lrwxr-xr-x   1 USER staff    34 May 21 15:00 .vimrc -> /Users/USER/code/vimsimple/vimrc

I've tried some of the suggestions from filed issues but no luck. If anyone can help get past this that would be bomb.

  • Based on the project's page and the way vim works, you need to install solarized for vim (using a plugin manager, packages, or something else) and then put a couple of instructions in your vimrc...
    – D. Ben Knoble
    Commented May 27, 2020 at 19:30
  • Does :set termguicolors fix it?
    – filbranden
    Commented May 27, 2020 at 19:31
  • I just spotted https://github.com/todd-dsm/vimSimple/blob/master/vim/vimrcs/colors.vim... you need to set the g: variable prior to color for it to have any effect. But I also didn't see it get sourced anywhere. Plus, if you have your terminal setup with the solarized palette, you don't need it. I did find it worked better in MacVim, though (tried in term w/o solarized palette)
    – D. Ben Knoble
    Commented May 27, 2020 at 19:36
  • @filbranden sadly no, I read the help and checked that vim was compiled with that feature (it is). When setting it, it just made the screen more blah: imgur.com/a/xMstl3D
    – todd_dsm
    Commented May 29, 2020 at 3:05
  • 1
    @todd_dsm colorscheme is not the variable I’m talking about. What about solarized_termcolors in the file I linked to?
    – D. Ben Knoble
    Commented May 29, 2020 at 19:12


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.