2

I have these following errors whenever I try to get into insert mode (see images). I am confused about how to resolve them. I did try uninstalling and reinstalling SirVer/ultisnips, but didn't change anything.

none

Error message text:

Error detected while processing /home/mahbub/.vim/bundle/ultisnips/autoload/UltiSnips.vim: line 7: E319: Sorry, the command is not available in this version: py3 import vim

enter image description here

Error message text:

Error detected while processing function UltiSnips#TrackChange: line 1: E319: Sorry, the command is not available in this version: py3 UltiSninps_Manager._track_change()

6
  • No, it doesn't have python support. I did try to add python support, but 2-3 techniques online didn't work, I am not sure how to add that either. I am using Linux (mint cinnamon), vim version is 8.2, the latest one, and I installed vim myself. May 24 '20 at 21:34
  • In trying to add python support, I thought let me just uninstall vim and the reinstall. So I had uninstalled vim including vim-tiny and reinstalled it. Do you think something wrong might have happened there? Kind of confused about how to fix it. May 24 '20 at 22:28
  • 1
    Please don’t post images of text
    – D. Ben Knoble
    May 24 '20 at 23:38
  • I tried all of them, vim-gtk, vim-nox, vim-gnome. Still the same error message. May 25 '20 at 8:30
  • I installed vim-gtk3 as well, still not working. May 25 '20 at 15:12
1

The error you are getting is happening because your Vim doesn't include support for Python, which is required by UltiSnips, as that plug-in is implemented in Python for the most part.

My recommendation is that you should get a Vim binary from your distribution. You mentioned using Linux Mint, so make sure you are not using a vim-tiny package, since that package is typically built with most features disabled. Instead, try vim-gtk, vim-gnome or vim-nox which should be more featureful versions of Vim.

You also mentioned in the comments that which vim points to /usr/local/bin/vim, please note that this path is most likely not the one for a Vim installed by your distribution. Instead, your distribution's Vim will be in /usr/bin/vim or /bin/vim (in modern distributions, these two last paths are typically the same, as /bin is usually a symbolic link to /usr/bin.)

Not sure how you got a Vim under /usr/local/bin/vim, did you happen to install Vim from source over there? Did you get a binary package from somewhere other than your distribution and unpacked it there? In any case, you might want to uninstall that one, to see if things start working back again.

If there's nothing other than Vim installed under /usr/local (you can maybe find that with a find /usr/local command to list all the files and subdirectories in there), you might be able to just remove that whole tree and recreate just the directories from scratch.

Another option is to change your $PATH variable to list /usr/bin ahead of /usr/local/bin, for example export PATH=/usr/bin:$PATH should do that for you. But that is just a workaround. The best option is to uninstall a Vim under /usr/local that is clearly not working for you, and make sure the one you install from your Linux distribution is a fully featured and not a minimal build.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – filbranden
    May 26 '20 at 19:09
0

I got same problem, tried changing location of vim to home directory. Then Solved 😎

1
  • 4
    Welcome to Vi and Vim! This answer would benefit from an edit that explains the solution and how it works further. For example, it is not clear what "changing location of vim to home directory" means.
    – D. Ben Knoble
    Jul 3 at 18:34

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .