2

enter image description here

If I run vim without tmux in urxvt v9.22 or xterm 330, it flicks after a full screen scroll.

$ seq 1000 >test
$ vim --clean test

execute G or /13$ and nnnnnnn, you should see it flickers. If you split your window with <c-w>v, the flicker vanishes away. If you maximize current window with <c-w>|, it still doesn't flicker. Looks like it only flicks when there is only 1 window.

gnome-terminal don't have this problem.

All test done in 256color terminfo, ubuntu18.04, vim8.2 1-803

How to deal with it?

Update

FWIW, scroll in terminal doesn't flicker, scroll in neovim doesn't flicker, only scroll in vim flicker.

I have tried apt version vim, and compiled vim7.4, 8.1, 8.2, and tried a version from some ppa, no luck.

I have tried to compile urxvt from here, no luck.

This is my rxvt, it's the only xresource.

This is my current vim

Have tried to turn off buggy options:

*.jumpScroll: false
*.borderLess: false
*.transparent: false

still no luck.

Update

Just learned to record terminal session by script, the result for urxvt and tmux inside urxvt (top one is urxvt):

113^M^[[?25l^[[27m^[[23m^[[29m^[[m^[[H^[[2J^[[1;1H102
113^M^[[?25l^[[27m^[[24m^[[23m^[[0m^[[H^[[J^[[1;1H103

113<cr> search 113, it cause a fullscreen scroll , then vim hide cursor, turn off invers, italic, cross-out, reset sgr ( the ^[[m or ^[[0m ), place cursor at 1,1, clear screen, place cursor at 1,1 ,start display new content (102 or 103 in the trail) . The biggest difference is the clear_screen (t_cl in termcap) escape sequence, urxvt use ^[[H^[[2J, tmux use ^[[H^[[J, I tried to use tmux t_cl in urxvt , but still no luck.

I don't use xterm, you can post answer that only work for urxvt, any help is appreciated.

4
  • I can't really this problem on my machine. Only tested xterm with the default settings. Perhaps there is some xterm setting that would affect this (I believe urxvt uses much of the same settings)? – Martin Tournoij Jun 1 '20 at 7:51
  • @MartinTournoij This is my rxvt, it's the only xresource, I have stopped loading ~/.Xresources.d/xterm, still no luck. – dedowsdi Jun 1 '20 at 8:10
  • Maybe :h 'ttyscroll' can help? – Matt Jun 7 '20 at 17:10
  • @Matt Tried ttyscroll=1 and ttyscroll=999, not working. – dedowsdi Jun 7 '20 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.