2

I am using the markdown extension plasticboy/vim-markdown to navigate inside large markdown files:

" :Toc : create a quickfix vertical window navigable table of contents with the headers."

enter image description here

Since I In installed the ALE linter, the content of the quick fix window disappears after I save the markdown file.

enter image description here

When I disable ALE, it works fine and the TOC content remains visible at all times, even after file save. I can disable ale temporarily in a buffer this way:

let b:ale_enabled = 0

But how Can I get plasticboy/vim-markdown to continue working properly when ALE is activated?

2

In the absence of a more elegant fix, I disabled ALE for markdown files as explained in ALE issue 371, by adding this to my ~/.vimrc:

" Disable ale for some file extensions 
let g:ale_pattern_options = {          
\   '.*\.md$': {'ale_enabled': 0},     
\   '.*\.Rmd$': {'ale_enabled': 0},    
\}                                     
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.