0

I installed the cool plugin ("thaerkh/vim-workspace") that make autosession and autosave. But I noticed that when I enter into vim again after quit, some options are rewritable. For example set noshowmode and I see mode in status line twice, cuz I use the airline status plugin.

How can I set this option permanent?

  • 1
    Welcome to Vi and Vim! I'm not sure I follow your question. You use airline, so the mode is the airline statusline, correct? That's separate from the showmode option, which uses a little "messages/command-line" area. – D. Ben Knoble May 11 at 23:03
  • 2
    @D.BenKnoble I think the OP means he wants to always have noshowmode because airline makes it redundant, but he seems not to be able to 'save' the setting. – Biggybi May 11 at 23:13
1

The basic way to have an option always applied is to put it in your vim config file (which is most probably your vimrc).

Drop set noshowmode in your vimrc and it should be done.

By default, though, settings are saved with your sessions. This behavior is dictated by the 'sessionoptions' option.

Your plugin may deactivate this, I'm not familiar with it though. If you wanted to not save options with the session, set sessionoptions-=options in your vimrc, or sessionoptions+=options for the opposite behavior (the default).

I just wanted to point this because your plugin seems to interfere with it, which seems to confuse you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.