12

No matter how I do it, I seem to get the nightly or the 0.2.2 version. How do I install the stable version of Neovim. I have too many issues in the nightly.

I used sudo apt install neovim and when I run nvim --version I get:

NVIM v0.5.0-nightly-6-gef0398f
Build type: Release
LuaJIT 2.1.0-beta3

3 Answers 3

20

There is ppa recommended on the project page:

sudo add-apt-repository ppa:neovim-ppa/stable 
sudo apt-get update
sudo apt-get install neovim

You'll get v0.4.3:

$ nvim --version                                                                                                                                           
NVIM v0.4.3
Build type: Release
LuaJIT 2.1.0-beta3
Compilation: /usr/bin/cc -g -O2 -fdebug-prefix-map=/build/neovim-U5Ub0w/neovim-0.4.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=1 -DDISABLE_LOG -Wdate-time -D_FORTIFY_SOURCE=1 -O2 -DNDEBUG -DMIN_LOG_LEVEL=3 -Wall -Wextra -pedantic -Wno-unused-parameter -Wstrict-prototypes -std=gnu99 -Wshadow -Wconversion -Wmissing-prototypes -Wimplicit-fallthrough -Wvla -fstack-protector-strong -fdiagnostics-color=always -DINCLUDE_GENERATED_DECLARATIONS -D_GNU_SOURCE -DNVIM_MSGPACK_HAS_FLOAT32 -DNVIM_UNIBI_HAS_VAR_FROM -I/build/neovim-U5Ub0w/neovim-0.4.3/build/config -I/build/neovim-U5Ub0w/neovim-0.4.3/src -I/usr/include -I/usr/include/lua5.1 -I/build/neovim-U5Ub0w/neovim-0.4.3/build/src/nvim/auto -I/build/neovim-U5Ub0w/neovim-0.4.3/build/include
Compiled by [email protected]

Features: +acl +iconv +tui
See ":help feature-compile"

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/share/nvim"

Run :checkhealth for more info
1
  • 1
    Just an update, the answer is still valid as in 2023 (Ubuntu 22.04.1 LTS) Commented Jan 20, 2023 at 5:26
3

Ubuntu 18.04 (Bionic) ships Neovim 0.2.2, so that explains why you'll get that version by default.

You can use a PPA from the “Neovim PPA” team to install the latest Neovim stable on your Ubuntu 18.04 (also available for 16.04 and 19.10)

Use these commands to configure your system to always include this PPA in updates:

sudo add-apt-repository ppa:neovim-ppa/stable
sudo apt-get update

It's odd that you have a Neovim v0.5.0-nightly installed in your system. If you're getting it from a deb package or from a different PPA, you might want to make sure you uninstall that before you'll be able to install the one from the Stable PPA.

2

Following worked on ubuntu 20.04 LTS

  1. Run the following curl command and this will create a nvim.appimage folder in your current folder.
  curl -LO https://github.com/neovim/neovim/releases/latest/download/nvim.appimage
  chmod u+x nvim.appimage
  1. Move the file to the following location
  sudo mv nvim.appimage /usr/local/bin 
  1. Finally remove .appimage from the file name
  sudo mv nvim.appimage nvim
  1. type "which nvim" on the terminal and it will show you the nvim path OR just type "nvim" on the terminal, it will open up the neovim

Hope it helps someone and these commands taken from the following official neovim repo. https://github.com/neovim/neovim/wiki/Installing-Neovim#appimage-universal-linux-package

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.