I've been using Vim Fugitive plugin for some time now. Recently, I tried the Vim rhubarb plugin.

So for a github-repo it should work out of the box but `:GBrowse doesn't open the browser at all.

Although, :Gbrowse! seems to work fine.

I believe it has to do with vim version.

I'm using apple compiled vim

VIM - Vi IMproved 8.1 (2018 May 18, compiled Nov 9 2019 02:36:49)

Included patches: 1-503, 505-680, 682-1312

  • Can you be more specific on how GBrowse doesn't work for you? Does it give any error messages? What if you look at :messages, do you see anything there? Does it do any other unexpected action, or does it just do nothing?
    – filbranden
    May 6, 2020 at 23:44
  • 1
    These kinds of questions are better asked on issue trackers, imo
    – D. Ben Knoble
    May 7, 2020 at 0:21
  • @filbranden When I run GBrowse it doesn't do anything like opening the code line in the browser. I ran :messages command after running GBrowse --- Messages maintainer: Bram Moolenaar <[email protected]> "osx_apps_install.sh" 114L, 2654C github.com/username/commands/blob/master/osx_apps_install.sh. Press ENTER or type command to continue.
    – ankitj
    May 7, 2020 at 18:59
  • @D.BenKnoble Just created one github.com/tpope/vim-rhubarb/issues/57
    – ankitj
    May 7, 2020 at 19:05
  • @filbranden Tried to run GBrowse on an enterprise repo. :messages gives me this output --- Messages maintainer: Bram Moolenaar <[email protected]> Error detected while processing function nerdtree#ui_glue#invokeKeyMap[1]..78[18]..77[3]..<SNR>33_customOpenFile[1]..107[1]..123[3]..179[6]..180[17]..14: line 3: E325: ATTENTION
    – ankitj
    May 7, 2020 at 20:24

1 Answer 1


The culprit was netrw plugin.

It's failing somehow and that's why browser doesn't open.

Maybe something to do the vim version as it works on a recent vim version.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.