I've been using Neovim for a few days with no problem, so I decided to switch my git config to use Neovim instead of vim. Here's what I put in my global .gitconfig:

    editor = nvim

And here's the warning when I run git commit now:

Warning: Cannot find word list "en.utf-8.spl" or "en.ascii.spl"
Press ENTER or type command to continue

After pressing a key, it works fine, except that it doesn't do spell checking like vim used to do. Here's what I've got in my .nvimrc to turn on spell checking in git commit messages.

autocmd Filetype gitcommit setlocal spell textwidth=72

1 Answer 1


If I run :set spell, I get:

spellfile#LoadFile(): There is no writable spell directory
Shall I create /Users/adamharris/.nvim/spell
(Y)es, [N]o: 

Select y

Cannot find spell file for "en" in utf-8
Do you want me to try downloading it?
(Y)es, [N]o: 

Select y, and it will download the file.

In which directory do you want to write the file:
1. /Users/adamharris/.nvim/spell
[C]ancel, (1):

Select 1

Do you want me to try to get the .sug file?
This will improve making suggestions for spelling mistakes,
but it uses quite a bit of memory.
[N]o, (Y)es:

I selected y, and downloaded the file.

Then spellchecking works just fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.