0

I can move down until the last line of a file with no issues. However, when move up the text that was out of screen bounds does not render (as shown by the figure) until i press Ctrl + L to force rendering. Text not rendered

My terminal is st. This is my .vimrc

" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
" you can find below.  If you wish to change any of those settings, you should
" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
" everytime an upgrade of the vim packages is performed.  It is recommended to
" make changes after sourcing archlinux.vim since it alters the value of the
" 'compatible' option.

" Disable Background Color Erase (BCE) so that color schemes
" render properly when inside 256-color tmux and GNU screen.
if &term =~ '256color'
    set t_ut=
endif

" This line should not be removed as it ensures that various options are
" properly set to work with the Vim-related packages.
runtime! archlinux.vim

" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
" Or better yet, read /usr/share/vim/vim80/vimrc_example.vim or the vim manual
" and configure vim to your own liking!

" do not load defaults if ~/.vimrc is missing
"let skip_defaults_vim=1

" adding my configs
:set lazyredraw 
:set history=500
:set number
:set mouse=a
:set clipboard+=unnamed  " use the clipboards of vim and win
:set paste               " Paste from a windows or from vim
:set go+=a               " Visual selection automatically copied to the clipboard
:set laststatus=2

" now this is configurations for plugins

if empty(glob('~/.vim/autoload/plug.vim'))
  silent !curl -fLo ~/.vim/autoload/plug.vim --create-dirs
    \ https://raw.githubusercontent.com/junegunn/vim-plug/master/plug.vim
  autocmd VimEnter * PlugInstall --sync | source $MYVIMRC
endif

" Specify a directory for plugins
" - For Neovim: stdpath('data') . '/plugged'
" - Avoid using standard Vim directory names like 'plugin'
call plug#begin('~/.vim/plugged')

Plug 'itchyny/lightline.vim'

" Initialize plugin system
call plug#end()
  • Welcome to Vi and Vim! Does this get fixed if you remove the set t_ut= line from your vimrc? It looks suspicious... What's your $TERM setting in the shell? Outside tmux? And inside tmux? You can also try to see whether removing set lazyredraw will improve it, but it might just make scrolling slower, so I'd check it mostly as "yeah, that fixes it but makes Vim less usable..." – filbranden Apr 23 at 17:11
  • 1
    removing set t_ut= and set lazyredraw do not help, even with the default .vimrc file i have the same problem. In TTY i do not have this issue. My $TERM is st-256color. – Roberto Rolo Apr 23 at 17:41
  • Did you apply any patches to st, or are you using the standard version? – Martin Tournoij Apr 23 at 17:54
  • Indeed the patching was the problem. I just repatched everything and now it works as it should! Many thanks for your help. – Roberto Rolo Apr 27 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.