0

Every time I run vim I receive the following error message that disappear afterwords. What can I do to get rid of that message or to get rid of the problem?

[deoplete] [yarp] [deoplete] job is dead. failed establishing channel for ['python3', '-u', '/home/sb/.vim/plugged/nvim-yarp/pythonx/yarp.py', '/tmp/vxXiDJM/0', 2, 'deoplete']
[deoplete] function deoplete#enable[9]..deoplete#initialize[1]..deoplete#init#_initialize[15]..deoplete#init#_channel[24]..yarp#core#notify[1]..yarp#core#wait_channel, line 13
3
  • Best is to file with deoplete author—theyll be able to help you debug the issue. In the meantime, you could disable deoplete to make the error go away, but you’ll lose the functionality
    – D. Ben Knoble
    Apr 21 '20 at 14:01
  • Thank you. I disabled it with let g:deoplete#enable_at_startup = 0.
    – sbac
    Apr 21 '20 at 14:12
  • please post your solution as an answer, so that it does not get lost
    – D. Ben Knoble
    Aug 9 at 11:24
1

I had the same issue and fixed with pip install --user pynvim

1
  • 1
    Welcome to this site :) Note that OP fixed their issue with let g:deoplete#enable_at_startup = 0 (they should have posted it as an answer). Also it would be worth adding to your answer that before trying to install pynvim one should check :checkhealth which will say if pynvim or other dependencies are needed.
    – statox
    Aug 9 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.